CVE-2021-3927

Name
CVE-2021-3927
Description
vim is vulnerable to Heap-based Buffer Overflow
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://huntr.dev/bounties/9c2b2c82-48bb-4be9-ab8f-a48ea252d1b0
MISC https://github.com/vim/vim/commit/0b5b06cb4777d1401fdf83e7d48d287662236e7e
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PGW56Z6IN4UVM3E5RXXF4G7LGGTRBI5C/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* vim >= None < 8.2.3581

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
vim 3.14-main 8.2.3437-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.13-main 8.2.3437-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.12-main 8.2.3437-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
vim 3.11-main 8.2.3437-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable