CVE-2021-37600

Name
CVE-2021-37600
Description
** DISPUTED ** An integer overflow in util-linux through 2.37.1 can potentially cause a buffer overflow if an attacker were able to use system resources in a way that leads to a large number in the /proc/sysvipc/sem file. NOTE: this is unexploitable in GNU C Library environments, and possibly in all realistic environments.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/karelzak/util-linux/commit/1c9143d0c1f979c3daf10e1c37b5b1e916c22a1c
MISC https://github.com/karelzak/util-linux/issues/1395
Third Party Advisory https://security.netapp.com/advisory/ntap-20210902-0002/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:kernel:util-linux:*:*:*:*:*:*:*:* util-linux >= None <= 2.37.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
util-linux 3.14-main 2.37.2-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
util-linux 3.13-main 2.36.1-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
util-linux 3.12-main 2.35.2-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
util-linux 3.11-main 2.34-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable