CVE-2021-36976

Name
CVE-2021-36976
Description
libarchive 3.4.1 through 3.5.1 has a use-after-free in copy_string (called from do_uncompress_block and process_block).
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=32375
MISC https://github.com/google/oss-fuzz-vulns/blob/main/vulns/libarchive/OSV-2021-557.yaml

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:libarchive:libarchive:*:*:*:*:*:*:*:* libarchive >= 3.4.1 <= 3.5.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libarchive 3.14-main 3.5.1-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libarchive 3.13-main 3.5.1-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libarchive 3.12-main 3.4.3-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libarchive 3.11-main 3.4.2-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable