CVE-2021-36213

Name
CVE-2021-36213
Description
HashiCorp Consul and Consul Enterprise 1.9.0 through 1.10.0 default deny policy with a single L7 application-aware intention deny action cancels out, causing the intention to incorrectly fail open, allowing L4 traffic. Fixed in 1.9.8 and 1.10.1.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.hashicorp.com/blog/category/consul
CONFIRM https://github.com/hashicorp/consul/releases/tag/v1.10.1
CONFIRM https://discuss.hashicorp.com/t/hcsec-2021-16-consul-s-application-aware-intentions-deny-action-fails-open-when-combined-with-default-deny-policy/26855

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:hashicorp:consul:*:*:*:*:-:*:*:* consul >= 1.9.0 < 1.9.8
cpe:2.3:a:hashicorp:consul:*:*:*:*:-:*:*:* consul >= 1.10.0 < 1.10.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
consul 3.14-community 1.9.6-r1 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable