CVE-2021-3498

Name
CVE-2021-3498
Description
GStreamer before 1.18.4 might cause heap corruption when parsing certain malformed Matroska files.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://gstreamer.freedesktop.org/security/sa-2021-0003.html
MISC https://bugzilla.redhat.com/show_bug.cgi?id=1945342
DEBIAN https://www.debian.org/security/2021/dsa-4900
MISC http://packetstormsecurity.com/files/162952/Gstreamer-Matroska-Demuxing-Use-After-Free.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gstreamer_project:gstreamer:*:*:*:*:*:*:*:* gstreamer >= 1.0.0 < 1.18.4

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
gstreamer edge-main 1.18.4-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
gst-plugins-good edge-community 1.18.4-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
gstreamer 3.13-main 1.18.4-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
gst-plugins-good 3.13-community 1.18.4-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
gstreamer 3.12-main 1.16.2-r2 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
gstreamer 3.11-main 1.16.2-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
gstreamer 3.10-main 1.16.0-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
gstreamer 3.14-main 1.18.4-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
gst-plugins-good 3.14-community 1.18.4-r0 Natanael Copa <ncopa@alpinelinux.org> fixed