CVE-2021-3466

Name
CVE-2021-3466
Description
A flaw was found in libmicrohttpd in versions before 0.9.71. A missing bounds check in the post_process_urlencoded function leads to a buffer overflow, allowing a remote attacker to write arbitrary data in an application that uses libmicrohttpd. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Issue Tracking https://bugzilla.redhat.com/show_bug.cgi?id=1939127
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4334XJNDJPYQNFE6S3S2KUJJ7TMHYCWL/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/K5NEPVGP3L2CZHLZ4UB44PEILHKPDBOG/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/75HDMREKITMGPGE62NP7KE62ZJVLETXN/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gnu:libmicrohttpd:*:*:*:*:*:*:*:* libmicrohttpd >= None < 0.9.71

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libmicrohttpd 3.11-main 0.9.69-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libmicrohttpd 3.10-main 0.9.64-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable