CVE-2021-32815

Name
CVE-2021-32815
Description
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The assertion failure is triggered when Exiv2 is used to modify the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when modifying the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `fi`. ### Patches The bug is fixed in version v0.27.5. ### References Regression test and bug fix: #1739 ### For more information Please see our [security policy](https://github.com/Exiv2/exiv2/security/policy) for information about Exiv2 security.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://github.com/Exiv2/exiv2/security/advisories/GHSA-mv9g-fxh2-m49m
MISC https://github.com/Exiv2/exiv2/pull/1739

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:exiv2:exiv2:*:*:*:*:*:*:*:* exiv2 >= None <= 0.27.4

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
exiv2 3.11-main 0.27.2-r3 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
exiv2 edge-community 0.27.5-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
exiv2 3.14-community 0.27.5-r0 Natanael Copa <ncopa@alpinelinux.org> fixed