CVE-2021-32765

Name
CVE-2021-32765
Description
Hiredis is a minimalistic C client library for the Redis database. In affected versions Hiredis is vulnurable to integer overflow if provided maliciously crafted or corrupted `RESP` `mult-bulk` protocol data. When parsing `multi-bulk` (array-like) replies, hiredis fails to check if `count * sizeof(redisReply*)` can be represented in `SIZE_MAX`. If it can not, and the `calloc()` call doesn't itself make this check, it would result in a short allocation and subsequent buffer overflow. Users of hiredis who are unable to update may set the [maxelements](https://github.com/redis/hiredis#reader-max-array-elements) context option to a value small enough that no overflow is possible.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://wiki.sei.cmu.edu/confluence/display/c/MEM07-C.+Ensure+that+the+arguments+to+calloc%28%29%2C+when+multiplied%2C+do+not+wrap
CONFIRM https://github.com/redis/hiredis/security/advisories/GHSA-hfm9-39pp-55p2
MISC https://github.com/redis/hiredis/commit/76a7b10005c70babee357a7d0f2becf28ec7ed1e
MLIST https://lists.debian.org/debian-lts-announce/2021/10/msg00007.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:redis:hiredis:*:*:*:*:*:*:*:* hiredis >= None < 1.0.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
hiredis 3.14-main 1.0.0-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
hiredis 3.13-main 1.0.0-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
hiredis 3.12-main 0.14.1-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
hiredis 3.11-main 0.14.0-r3 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable