CVE-2021-32546

Name
CVE-2021-32546
Description
Missing input validation in internal/db/repo_editor.go in Gogs before 0.12.8 allows an attacker to execute code remotely. An unprivileged attacker (registered user) can overwrite the Git configuration in his repository. This leads to Remote Command Execution, because that configuration can contain an option such as sshCommand, which is executed when a master branch is a remote branch (using an ssh:// URI). The remote branch can also be configured by editing the Git configuration file. One can create a new file in a new repository, using the GUI, with "\" as its name, and then rename this file to .git/config with the custom configuration content (and then save it).
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/gogs/gogs/releases
MISC https://github.com/gogs/gogs/security/advisories/GHSA-56j7-2pm8-rgmx

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gogs:gogs:*:*:*:*:*:*:*:* gogs >= None < 0.12.8

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
gogs 3.16-community 0.12.7-r0 None possibly vulnerable