CVE-2021-31879

Name
CVE-2021-31879
Description
GNU Wget through 1.21.1 does not omit the Authorization header upon a redirect to a different origin, a related issue to CVE-2018-1000007.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://mail.gnu.org/archive/html/bug-wget/2021-02/msg00002.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gnu:wget:*:*:*:*:*:*:*:* wget >= None <= 1.21.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
wget edge-main 1.21.1-r1 Carlo Landmeter <clandmeter@alpinelinux.org> possibly vulnerable
wget 3.13-main 1.21.1-r1 Carlo Landmeter <clandmeter@alpinelinux.org> possibly vulnerable
wget 3.12-main 1.20.3-r1 Carlo Landmeter <clandmeter@gmail.com> possibly vulnerable
wget 3.11-main 1.20.3-r0 Carlo Landmeter <clandmeter@gmail.com> possibly vulnerable
wget 3.10-main 1.20.3-r0 Carlo Landmeter <clandmeter@gmail.com> possibly vulnerable
wget 3.14-main 1.21.1-r1 Carlo Landmeter <clandmeter@alpinelinux.org> possibly vulnerable