CVE-2021-31808

Name
CVE-2021-31808
Description
An issue was discovered in Squid before 4.15 and 5.x before 5.0.6. Due to an input-validation bug, it is vulnerable to a Denial of Service attack (against all clients using the proxy). A client sends an HTTP Range request to trigger this.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/squid-cache/squid/security/advisories/GHSA-pxwq-f3qr-w2xf
MISC http://www.squid-cache.org/Versions/v4/changesets/squid-4-e7cf864f938f24eea8af0692c04d16790983c823.patch
DEBIAN https://www.debian.org/security/2021/dsa-4924
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T4EPIWUZDJAXADDHVOPKRBTQHPBR6H66/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LSQ3U54ZCNXR44QRPW3AV2VCS6K3TKCF/
MLIST https://lists.debian.org/debian-lts-announce/2021/06/msg00014.html
Third Party Advisory https://security.netapp.com/advisory/ntap-20210716-0007/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:squid-cache:squid:*:*:*:*:*:*:*:* squid >= None < 4.15
cpe:2.3:a:squid-cache:squid:*:*:*:*:*:*:*:* squid >= 5.0 < 5.0.6

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
squid 3.10-main 4.15-r0 Natanael Copa <ncopa@alpinelinux.org> fixed