CVE-2021-3156

Name
CVE-2021-3156
Description
Sudo before 1.9.5p2 contains an off-by-one error that can result in a heap-based buffer overflow, which allows privilege escalation to root via "sudoedit -s" and a command-line argument that ends with a single backslash character.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://www.openwall.com/lists/oss-security/2021/01/26/3
Release Notes https://www.sudo.ws/stable.html#1.9.5p2
Exploit http://www.openwall.com/lists/oss-security/2021/01/26/3
Third Party Advisory https://security.gentoo.org/glsa/202101-33
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LHXK6ICO5AYLGFK2TAX5MZKUXTUKWOJY/
Third Party Advisory https://www.debian.org/security/2021/dsa-4839
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/CALA5FTXIQBRRYUA2ZQNJXB6OQMAXEII/
Mailing List http://www.openwall.com/lists/oss-security/2021/01/27/1
Mailing List http://www.openwall.com/lists/oss-security/2021/01/27/2
Third Party Advisory http://packetstormsecurity.com/files/161160/Sudo-Heap-Based-Buffer-Overflow.html
Third Party Advisory https://security.netapp.com/advisory/ntap-20210128-0001/
Third Party Advisory https://security.netapp.com/advisory/ntap-20210128-0002/
Third Party Advisory https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-sudo-privesc-jan2021-qnYQfcM
Exploit http://packetstormsecurity.com/files/161230/Sudo-Buffer-Overflow-Privilege-Escalation.html
Exploit http://packetstormsecurity.com/files/161270/Sudo-1.9.5p1-Buffer-Overflow-Privilege-Escalation.html
Third Party Advisory https://www.kb.cert.org/vuls/id/794544
Exploit http://packetstormsecurity.com/files/161293/Sudo-1.8.31p2-1.9.5p1-Buffer-Overflow.html
Third Party Advisory https://support.apple.com/kb/HT212177
Mailing List http://seclists.org/fulldisclosure/2021/Feb/42
Third Party Advisory https://kc.mcafee.com/corporate/index?page=content&id=SB10348
Exploit http://www.openwall.com/lists/oss-security/2021/02/15/1
Mailing List https://lists.debian.org/debian-lts-announce/2021/01/msg00022.html
Exploit http://seclists.org/fulldisclosure/2021/Jan/79
Patch https://www.beyondtrust.com/blog/entry/security-advisory-privilege-management-for-unix-linux-pmul-basic-and-privilege-management-for-mac-pmm-affected-by-sudo-vulnerability
Third Party Advisory https://www.synology.com/security/advisory/Synology_SA_21_02
Patch https://www.oracle.com//security-alerts/cpujul2021.html
Mailing List http://www.openwall.com/lists/oss-security/2021/09/14/2
MISC https://www.oracle.com/security-alerts/cpuoct2021.html
MISC https://www.oracle.com/security-alerts/cpuapr2022.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:sudo_project:sudo:*:*:*:*:*:*:*:* sudo >= None < 1.9.5
cpe:2.3:a:sudo_project:sudo:*:*:*:*:*:*:*:* sudo >= 1.8.2 < 1.8.32
cpe:2.3:a:sudo_project:sudo:*:*:*:*:*:*:*:* sudo >= 1.9.0 < 1.9.5

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
sudo 3.12-main 1.9.5p2-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
sudo 3.10-main 1.9.5p2-r0 Natanael Copa <ncopa@alpinelinux.org> fixed