CVE-2021-30799

Name
CVE-2021-30799
Description
Multiple memory corruption issues were addressed with improved memory handling. This issue is fixed in iOS 14.7, macOS Big Sur 11.5, Security Update 2021-004 Catalina, Security Update 2021-005 Mojave. Processing maliciously crafted web content may lead to arbitrary code execution.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://support.apple.com/en-us/HT212602
MISC https://support.apple.com/en-us/HT212603
MISC https://support.apple.com/en-us/HT212600
MISC https://support.apple.com/en-us/HT212601

Match rules

CPE URI Source package Min version Max version
cpe:2.3:o:apple:iphone_os:*:*:*:*:*:*:*:* iphone_os >= None < 14.7
cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* mac_os_x >= 10.14 <= 10.14.6
cpe:2.3:o:apple:mac_os_x:10.14.6:security_update_2019-001:*:*:*:*:*:* mac_os_x == None == 10.14.6
cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* mac_os_x >= 10.15 < 10.15.7
cpe:2.3:o:apple:mac_os_x:10.15.6:supplemental_update:*:*:*:*:*:* mac_os_x == None == 10.15.6
cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2020:*:*:*:*:*:* mac_os_x == None == 10.15.7
cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* macos >= 11.0 < 11.5

Vulnerable and fixed packages

Source package Branch Version Maintainer Status