CVE-2021-30470

Name
CVE-2021-30470
Description
A flaw was found in PoDoFo 0.9.7. An uncontrolled recursive call among PdfTokenizer::ReadArray(), PdfTokenizer::GetNextVariant() and PdfTokenizer::ReadDataType() functions can lead to a stack overflow.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugzilla.redhat.com/show_bug.cgi?id=1947436

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:podofo_project:podofo:0.9.7:*:*:*:*:*:*:* podofo == None == 0.9.7

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
podofo 3.14-community 0.9.7-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
podofo edge-community 0.9.7-r1 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable