CVE-2021-30157

Name
CVE-2021-30157
Description
An issue was discovered in MediaWiki before 1.31.12 and 1.32.x through 1.35.x before 1.35.2. On ChangesList special pages such as Special:RecentChanges and Special:Watchlist, some of the rcfilters-filter-* label messages are output in HTML unescaped, leading to XSS.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Exploit https://phabricator.wikimedia.org/T278058
Third Party Advisory https://www.debian.org/security/2021/dsa-4889
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/26UJGHF7LJDOCQN6A3Z4PM7PYRKENJHE/
Third Party Advisory https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2OMSV7B2TCFBOCICN3B4SMQP5HVRJQIT/
GENTOO https://security.gentoo.org/glsa/202107-40

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* mediawiki >= None < 1.31.12
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* mediawiki >= 1.32.0 < 1.35.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status