CVE-2021-29974

Name
CVE-2021-29974
Description
When network partitioning was enabled, e.g. as a result of Enhanced Tracking Protection settings, a TLS error page would allow the user to override an error on a domain which had specified HTTP Strict Transport Security (which implies that the error should not be override-able.) This issue did not affect the network connections, and they were correctly upgraded to HTTPS automatically. This vulnerability affects Firefox < 90.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugzilla.mozilla.org/show_bug.cgi?id=1704843
MISC https://www.mozilla.org/security/advisories/mfsa2021-28/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:* firefox >= None < 90.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
firefox 3.14-community 89.0.1-r0 Rasmus Thomsen <oss@cogitri.dev> possibly vulnerable