CVE-2021-29971

Name
CVE-2021-29971
Description
If a user had granted a permission to a webpage and saved that grant, any webpage running on the same host - irrespective of scheme or port - would be granted that permission. *This bug only affects Firefox for Android. Other operating systems are unaffected.*. This vulnerability affects Firefox < 90.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugzilla.mozilla.org/show_bug.cgi?id=1713638
MISC https://www.mozilla.org/security/advisories/mfsa2021-28/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mozilla:firefox:*:*:*:*:*:android:*:* firefox >= None < 90.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
firefox 3.14-community 89.0.1-r0 Rasmus Thomsen <oss@cogitri.dev> possibly vulnerable