CVE-2021-27218

Name
CVE-2021-27218
Description
An issue was discovered in GNOME GLib before 2.66.7 and 2.67.x before 2.67.4. If g_byte_array_new_take() was called with a buffer of 4GB or more on a 64-bit platform, the length would be truncated modulo 2**32, causing unintended length truncation.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Patch https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1942
Patch https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1944
Mailing List https://lists.apache.org/thread.html/rf9fa47ab66495c78bb4120b0754dd9531ca2ff0430f6685ac9b07772@%3Cdev.mina.apache.org%3E
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2REA7RVKN7ZHRLJOEGBRQKJIPZQPAELZ/
Third Party Advisory https://security.netapp.com/advisory/ntap-20210319-0004/
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/JJMPNDO4GDVURYQFYKFOWY5HAF4FTEPN/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gnome:glib:*:*:*:*:*:*:*:* glib >= None < 2.66.7
cpe:2.3:a:gnome:glib:*:*:*:*:*:*:*:* glib >= 2.67.0 < 2.67.4

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
glib 3.12-main 2.64.6-r0 Rasmus Thomsen <oss@cogitri.dev> possibly vulnerable
glib 3.11-main 2.62.6-r0 Rasmus Thomsen <oss@cogitri.dev> possibly vulnerable
glib 3.10-main 2.60.4-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable