CVE-2021-23968

Name
CVE-2021-23968
Description
If Content Security Policy blocked frame navigation, the full destination of a redirect served in the frame was reported in the violation report; as opposed to the original frame URI. This could be used to leak sensitive information contained in such URIs. This vulnerability affects Firefox < 86, Thunderbird < 78.8, and Firefox ESR < 78.8.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Issue Tracking https://bugzilla.mozilla.org/show_bug.cgi?id=1687342
Release Notes https://www.mozilla.org/security/advisories/mfsa2021-08/
Release Notes https://www.mozilla.org/security/advisories/mfsa2021-09/
Release Notes https://www.mozilla.org/security/advisories/mfsa2021-07/
Mailing List https://lists.debian.org/debian-lts-announce/2021/03/msg00000.html
Third Party Advisory https://www.debian.org/security/2021/dsa-4866
GENTOO https://security.gentoo.org/glsa/202104-09
GENTOO https://security.gentoo.org/glsa/202104-10

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:* firefox >= None < 86.0
cpe:2.3:a:mozilla:firefox_esr:*:*:*:*:*:*:*:* firefox_esr >= None < 78.8
cpe:2.3:a:mozilla:thunderbird:*:*:*:*:*:*:*:* thunderbird >= None < 78.8

Vulnerable and fixed packages

Source package Branch Version Maintainer Status