CVE-2021-23437

Name
CVE-2021-23437
Description
The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://pillow.readthedocs.io/en/stable/releasenotes/8.3.2.html
CONFIRM https://github.com/python-pillow/Pillow/commit/9e08eb8f78fdfd2f476e1b20b7cf38683754866b
CONFIRM https://snyk.io/vuln/SNYK-PYTHON-PILLOW-1319443
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VKRCL7KKAKOXCVD7M6WC5OKFGL4L3SJT/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RNSG6VFXTAROGF7ACYLMAZNQV4EJ6I2C/
report@snyk.io https://lists.debian.org/debian-lts-announce/2024/03/msg00021.html
report@snyk.io https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RNSG6VFXTAROGF7ACYLMAZNQV4EJ6I2C/
report@snyk.io https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VKRCL7KKAKOXCVD7M6WC5OKFGL4L3SJT/
Third Party Advisory https://security.gentoo.org/glsa/202211-10

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* pillow >= None < 8.3.2
cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* pillow >= 5.2.0 < 8.3.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
py3-pillow 3.14-main 8.2.0-r1 Fabian Affolter <fabian@affolter-engineering.ch> fixed
py3-pillow 3.13-main 7.2.0-r2 Fabian Affolter <fabian@affolter-engineering.ch> fixed
py3-pillow 3.12-main 7.1.2-r2 Fabian Affolter <fabian@affolter-engineering.ch> fixed
py-pillow 3.11-main 6.2.1-r1 Fabian Affolter <fabian@affolter-engineering.ch> fixed