CVE-2021-22930

Name
CVE-2021-22930
Description
Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://hackerone.com/reports/1238162
MISC https://nodejs.org/en/blog/vulnerability/july-2021-security-releases-2/
Third Party Advisory https://security.netapp.com/advisory/ntap-20211112-0002/
Patch https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
Mailing List https://lists.debian.org/debian-lts-announce/2022/10/msg00006.html
support@hackerone.com https://security.gentoo.org/glsa/202401-02

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* nodejs >= 12.0.0 < 12.22.4
cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* nodejs >= 14.0.0 < 14.17.4
cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* nodejs >= 16.0.0 < 16.6.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status