CVE-2021-22241

Name
CVE-2021-22241
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 14.0. It was possible to exploit a stored cross-site-scripting via a specifically crafted default branch name.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://hackerone.com/reports/1256777
MISC https://gitlab.com/gitlab-org/gitlab/-/issues/336460
CONFIRM https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22241.json

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 14.0.0 < 14.0.7
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 14.1.0 < 14.1.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status