CVE-2021-22211

Name
CVE-2021-22211
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.7. GitLab Dependency Proxy, under certain circumstances, can impersonate a user resulting in possibly incorrect access handling.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://gitlab.com/gitlab-org/gitlab/-/issues/298847
CONFIRM https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22211.json

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 13.7.0: < 13.9.7:
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 13.10.0: < 13.10.4:
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 13.11.0: < 13.11.2:
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 13.7.0 < 13.9.7
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 13.10.0 < 13.10.4
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* gitlab >= 13.11.0 < 13.11.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status