CVE-2021-22135

Name
CVE-2021-22135
Description
Elasticsearch versions before 7.11.2 and 6.8.15 contain a document disclosure flaw was found in the Elasticsearch suggester and profile API when Document and Field Level Security are enabled. The suggester and profile API are normally disabled for an index when document level security is enabled on the index. Certain queries are able to enable the profiler and suggester which could lead to disclosing the existence of documents and fields the attacker should not be able to view.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://discuss.elastic.co/t/elastic-stack-7-12-0-and-6-8-15-security-update/268125
Third Party Advisory https://security.netapp.com/advisory/ntap-20210625-0003/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:* elasticsearch >= None < 6.8.15
cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:* elasticsearch >= 7.11.0 < 7.11.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status