CVE-2021-21704

Name
CVE-2021-21704
Description
In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using Firebird PDO driver extension, a malicious database server could cause crashes in various database functions, such as getAttribute(), execute(), fetch() and others by returning invalid response data that is not parsed correctly by the driver. This can result in crashes, denial of service or potentially memory corruption.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://bugs.php.net/bug.php?id=76450
CONFIRM https://bugs.php.net/bug.php?id=76452
CONFIRM https://bugs.php.net/bug.php?id=76449
CONFIRM https://bugs.php.net/bug.php?id=76448
Third Party Advisory https://security.netapp.com/advisory/ntap-20211029-0006/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:php:php:*:*:*:*:*:*:*:* php >= 7.3.0 < 7.3.29
cpe:2.3:a:php:php:*:*:*:*:*:*:*:* php >= 7.4.0 < 7.4.21
cpe:2.3:a:php:php:*:*:*:*:*:*:*:* php >= 8.0.0 < 8.0.8

Vulnerable and fixed packages

Source package Branch Version Maintainer Status