CVE-2021-21701

Name
CVE-2021-21701
Description
Jenkins Performance Plugin 3.20 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2021-11-12/#SECURITY-2394
MLIST http://www.openwall.com/lists/oss-security/2021/11/12/1
Third Party Advisory https://www.zerodayinitiative.com/advisories/ZDI-21-1313/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:performance:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.20

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins edge-community 2.307-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable