CVE-2021-21700

Name
CVE-2021-21700
Description
Jenkins Scriptler Plugin 3.3 and earlier does not escape the name of scripts on the UI when asking to confirm their deletion, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by exploitable by attackers able to create Scriptler scripts.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2021-11-12/#SECURITY-2406
MLIST http://www.openwall.com/lists/oss-security/2021/11/12/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:scriptler:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins edge-community 2.307-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable