CVE-2021-21684

Name
CVE-2021-21684
Description
Jenkins Git Plugin 4.8.2 and earlier does not escape the Git SHA-1 checksum parameters provided to commit notifications when displaying them in a build cause, resulting in a stored cross-site scripting (XSS) vulnerability.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2021-10-06/#SECURITY-2499
MLIST http://www.openwall.com/lists/oss-security/2021/10/06/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:git:*:*:*:*:*:jenkins:*:* jenkins >= None <= 4.8.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins edge-community 2.307-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable