CVE-2021-21667

Name
CVE-2021-21667
Description
Jenkins Scriptler Plugin 3.2 and earlier does not escape parameter names shown in job configuration forms, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Scriptler/Configure permission.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2021-06-16/#SECURITY-2224
MLIST http://www.openwall.com/lists/oss-security/2021/06/16/3

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:scriptler:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.307-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable