CVE-2021-21645

Name
CVE-2021-21645
Description
Jenkins Config File Provider Plugin 3.7.0 and earlier does not perform permission checks in several HTTP endpoints, attackers with Overall/Read permission to enumerate configuration file IDs.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2021-04-21/#SECURITY-2203
MLIST http://www.openwall.com/lists/oss-security/2021/04/21/2

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:config_file_provider:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.7.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.13-community 2.287-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.303-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable