CVE-2021-21626

Name
CVE-2021-21626
Description
Jenkins Warnings Next Generation Plugin 8.4.4 and earlier does not perform a permission check in methods implementing form validation, allowing attackers with Item/Read permission but without Item/Workspace or Item/Configure permission to check whether attacker-specified file patterns match workspace contents.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://www.jenkins.io/security/advisory/2021-03-18/#SECURITY-2041
Third Party Advisory http://www.openwall.com/lists/oss-security/2021/03/18/5

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:warnings_next_generation:*:*:*:*:*:jenkins:*:* jenkins >= None <= 8.4.4

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.13-community 2.287-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.303-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable