CVE-2021-21624

Name
CVE-2021-21624
Description
An incorrect permission check in Jenkins Role-based Authorization Strategy Plugin 3.1 and earlier allows attackers with Item/Read permission on nested items to access them, even if they lack Item/Read permission for parent folders.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://www.jenkins.io/security/advisory/2021-03-18/#SECURITY-2182
Third Party Advisory http://www.openwall.com/lists/oss-security/2021/03/18/5

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:role-based_authorization_strategy:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.13-community 2.287-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.15-community 2.307-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.319.1-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable