CVE-2020-35479

Name
CVE-2020-35479
Description
MediaWiki before 1.35.1 allows XSS via BlockLogFormatter.php. Language::translateBlockExpiry itself does not escape in all code paths. For example, the return of Language::userTimeAndDate is is always unsafe for HTML in a month value. This affects MediaWiki 1.12.0 and later.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Mailing List https://lists.wikimedia.org/pipermail/mediawiki-announce/2020-December/000268.html
Exploit https://phabricator.wikimedia.org/T268938
Third Party Advisory https://www.debian.org/security/2020/dsa-4816
Mailing List https://lists.debian.org/debian-lts-announce/2020/12/msg00034.html
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/STT5Z4A3BCXVH3WIPICWU2FP4IPIMUPC/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* mediawiki >= 1.12.0 < 1.35.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status