CVE-2020-35457

Name
CVE-2020-35457
Description
** DISPUTED ** GNOME GLib before 2.65.3 has an integer overflow, that might lead to an out-of-bounds write, in g_option_group_add_entries. NOTE: the vendor's position is "Realistically this is not a security issue. The standard pattern is for callers to provide a static list of option entries in a fixed number of calls to g_option_group_add_entries()." The researcher states that this pattern is undocumented.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Patch https://gitlab.gnome.org/GNOME/glib/-/commit/63c5b62f0a984fac9a9700b12f54fe878e016a5d
Release Notes https://gitlab.gnome.org/GNOME/glib/-/releases/2.65.3
Exploit https://gitlab.gnome.org/GNOME/glib/-/issues/2197

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gnome:glib:*:*:*:*:*:*:*:* glib >= None < 2.65.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
glib 3.12-main 2.64.6-r0 Rasmus Thomsen <oss@cogitri.dev> possibly vulnerable
glib 3.11-main 2.62.6-r0 Rasmus Thomsen <oss@cogitri.dev> possibly vulnerable
glib 3.10-main 2.60.4-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable