CVE-2020-27841

Name
CVE-2020-27841
Description
There's a flaw in openjpeg in versions prior to 2.4.0 in src/lib/openjp2/pi.c. When an attacker is able to provide crafted input to be processed by the openjpeg encoder, this could cause an out-of-bounds read. The greatest impact from this flaw is to application availability.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Issue Tracking https://bugzilla.redhat.com/show_bug.cgi?id=1907510
Mailing List https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WJUPGIZE6A4O52EBOF75MCXJOL6MUCRV/
Third Party Advisory https://security.gentoo.org/glsa/202101-29
Mailing List https://lists.debian.org/debian-lts-announce/2021/02/msg00011.html
DEBIAN https://www.debian.org/security/2021/dsa-4882
MISC https://www.oracle.com/security-alerts/cpuApr2021.html
N/A https://www.oracle.com//security-alerts/cpujul2021.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:uclouvain:openjpeg:*:*:*:*:*:*:*:* openjpeg >= None < 2.4.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status