CVE-2020-25691

Name
CVE-2020-25691
Description
A flaw was found in darkhttpd. Invalid error handling allows remote attackers to cause denial-of-service by accessing a file with a large modification date. The highest threat from this vulnerability is to system availability.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugzilla.redhat.com/show_bug.cgi?id=1893725

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:darkhttpd_project:darkhttpd:*:*:*:*:*:*:*:* darkhttpd >= None <= 1.13-1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
darkhttpd edge-main 1.13-r0 Alan Lacerda <alacerda@alpinelinux.org> possibly vulnerable
darkhttpd 3.15-main 1.13-r0 Alan Lacerda <alacerda@alpinelinux.org> possibly vulnerable
darkhttpd 3.14-main 1.13-r0 Alan Lacerda <alacerda@alpinelinux.org> possibly vulnerable
darkhttpd 3.13-main 1.12-r6 Alan Lacerda <alacerda@alpinelinux.org> possibly vulnerable
darkhttpd 3.12-main 1.12-r5 Alan Lacerda <alacerda@alpinelinux.org> possibly vulnerable