CVE-2020-25637

Name
CVE-2020-25637
Description
A double free memory issue was found to occur in the libvirt API, in versions before 6.8.0, responsible for requesting information about network interfaces of a running QEMU domain. This flaw affects the polkit access control driver. Specifically, clients connecting to the read-write socket with limited ACL permissions could use this flaw to crash the libvirt daemon, resulting in a denial of service, or potentially escalate their privileges on the system. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Issue Tracking https://bugzilla.redhat.com/show_bug.cgi?id=1881037
SUSE http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00073.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00072.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:redhat:libvirt:*:*:*:*:*:*:*:* libvirt >= None < 6.8.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libvirt 3.12-main 6.6.0-r4 Francesco Colista <fcolista@alpinelinux.org> fixed
libvirt 3.11-main 5.9.0-r2 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
libvirt 3.10-main 5.5.0-r2 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable