CVE-2020-2280

Name
CVE-2020-2280
Description
A cross-site request forgery (CSRF) vulnerability in Jenkins Warnings Plugin 5.0.1 and earlier allows attackers to execute arbitrary code.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://www.jenkins.io/security/advisory/2020-09-23/#SECURITY-2042
Third Party Advisory http://www.openwall.com/lists/oss-security/2020/09/23/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:warnings:*:*:*:*:*:jenkins:*:* jenkins >= None <= 5.0.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.13-community 2.287-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.15-community 2.307-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.319.1-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable