CVE-2020-22628

Name
CVE-2020-22628
Description
Buffer Overflow vulnerability in LibRaw::stretch() function in libraw\src\postprocessing\aspect_ratio.cpp.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/LibRaw/LibRaw/issues/269

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:libraw:libraw:*:*:*:*:*:*:*:* libraw >= None < 2019-11-20

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libraw 3.18-community 0.21.1-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libraw 3.19-community 0.21.1-r2 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libraw edge-community 0.21.2-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libraw 3.20-community 0.21.2-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable