CVE-2020-2258

Name
CVE-2020-2258
Description
Jenkins Health Advisor by CloudBees Plugin 3.2.0 and earlier does not correctly perform a permission check in an HTTP endpoint, allowing attackers with Overall/Read permission to view that HTTP endpoint.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://www.jenkins.io/security/advisory/2020-09-16/#SECURITY-1998
Third Party Advisory http://www.openwall.com/lists/oss-security/2020/09/16/3

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:health_advisor_by_cloudbees:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.2.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.13-community 2.287-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.303-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable