CVE-2020-2243

Name
CVE-2020-2243
Description
Jenkins Cadence vManager Plugin 3.0.4 and earlier does not escape build descriptions in tooltips, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Run/Update permission.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://jenkins.io/security/advisory/2020-09-01/#SECURITY-1936
Mailing List http://www.openwall.com/lists/oss-security/2020/09/01/3

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:cadence_vmanager:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.0.4

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.13-community 2.287-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.15-community 2.307-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.319.1-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable