CVE-2020-2202

Name
CVE-2020-2202
Description
A missing permission check in Jenkins Fortify on Demand Plugin 6.0.0 and earlier in form-related methods allowed users with Overall/Read access to enumerate credentials ID of credentials stored in Jenkins.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Third Party Advisory https://jenkins.io/security/advisory/2020-07-02/#SECURITY-1690
Mailing List http://www.openwall.com/lists/oss-security/2020/07/02/7

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:fortify_on_demand:*:*:*:*:*:jenkins:*:* jenkins >= None <= 6.0.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.13-community 2.287-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.15-community 2.307-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.319.1-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable