CVE-2020-2136

Name
CVE-2020-2136
Description
Jenkins Git Plugin 4.2.0 and earlier does not escape the error message for the repository URL for Microsoft TFS field form validation, resulting in a stored cross-site scripting vulnerability.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://jenkins.io/security/advisory/2020-03-09/#SECURITY-1723
Third Party Advisory http://www.openwall.com/lists/oss-security/2020/03/09/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:git:*:*:*:*:*:jenkins:*:* jenkins >= None <= 4.2.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.13-community 2.287-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.14-community 2.297-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.303-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable