CVE-2020-15305

Name
CVE-2020-15305
Description
An issue was discovered in OpenEXR before 2.5.2. Invalid input could cause a use-after-free in DeepScanLineInputFile::DeepScanLineInputFile() in IlmImf/ImfDeepScanLineInputFile.cpp.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Release Notes https://github.com/AcademySoftwareFoundation/openexr/blob/master/CHANGES.md
Third Party Advisory https://github.com/AcademySoftwareFoundation/openexr/blob/master/SECURITY.md
Release Notes https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v2.5.2
Third Party Advisory https://github.com/AcademySoftwareFoundation/openexr/pull/730
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/SHYAKRAUEMYVCV7U5WLDRE2YFGSV5PIT/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/LKDRVXORM2VLNHRLFKS3JHRABSHZ5W5M/
UBUNTU https://usn.ubuntu.com/4418-1/
SUSE http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00025.html
SUSE http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00048.html
DEBIAN https://www.debian.org/security/2020/dsa-4755
MLIST https://lists.debian.org/debian-lts-announce/2020/08/msg00056.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:openexr:openexr:*:*:*:*:*:*:*:* openexr >= None < 2.5.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status