CVE-2020-15173

Name
CVE-2020-15173
Description
In ACCEL-PPP (an implementation of PPTP/PPPoE/L2TP/SSTP), there is a buffer overflow when receiving an l2tp control packet ith an AVP which type is a string and no hidden flags, length set to less than 6. If your application is used in open networks or there are untrusted nodes in the network it is highly recommended to apply the patch. The problem was patched with commit 2324bcd5ba12cf28f47357a8f03cd41b7c04c52b As a workaround changes of commit 2324bcd5ba12cf28f47357a8f03cd41b7c04c52b can be applied to older versions.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Third Party Advisory https://github.com/accel-ppp/accel-ppp/security/advisories/GHSA-rr68-fchr-69vf
Patch https://github.com/accel-ppp/accel-ppp/commit/2324bcd5ba12cf28f47357a8f03cd41b7c04c52b

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:accel-ppp:accel-ppp:*:*:*:*:*:*:*:* accel-ppp >= None <= 1.12.0-92-g38b6104

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
accel-ppp edge-community 1.12.0.141-r3 Thomas Liske <thomas@fiasko-nw.net> possibly vulnerable