CVE-2020-14404

Name
CVE-2020-14404
Description
An issue was discovered in LibVNCServer before 0.9.13. libvncserver/rre.c allows out-of-bounds access via encodings.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Release Notes https://github.com/LibVNC/libvncserver/compare/LibVNCServer-0.9.12...LibVNCServer-0.9.13
Patch https://github.com/LibVNC/libvncserver/commit/74e8a70f2c9a5248d6718ce443e07c7ed314dfff
Mailing List https://lists.debian.org/debian-lts-announce/2020/06/msg00035.html
Third Party Advisory https://usn.ubuntu.com/4434-1/
MLIST https://lists.debian.org/debian-lts-announce/2020/08/msg00045.html
UBUNTU https://usn.ubuntu.com/4573-1/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:libvncserver_project:libvncserver:*:*:*:*:*:*:*:* libvncserver >= None < 0.9.13

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libvncserver 3.11-main 0.9.12-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libvncserver 3.10-main 0.9.11-r3 None possibly vulnerable