CVE-2020-14401

Name
CVE-2020-14401
Description
An issue was discovered in LibVNCServer before 0.9.13. libvncserver/scale.c has a pixel_value integer overflow.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Patch https://github.com/LibVNC/libvncserver/commit/a6788d1da719ae006605b78d22f5a9f170b423af
Release Notes https://github.com/LibVNC/libvncserver/compare/LibVNCServer-0.9.12...LibVNCServer-0.9.13
Mailing List https://lists.debian.org/debian-lts-announce/2020/06/msg00035.html
Mailing List http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00033.html
Mailing List http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00055.html
Mailing List http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00066.html
Third Party Advisory https://usn.ubuntu.com/4434-1/
MLIST https://lists.debian.org/debian-lts-announce/2020/08/msg00045.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:libvncserver_project:libvncserver:*:*:*:*:*:*:*:* libvncserver >= None < 0.9.13

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libvncserver 3.11-main 0.9.12-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libvncserver 3.10-main 0.9.11-r3 None possibly vulnerable