CVE-2020-13223

Name
CVE-2020-13223
Description
HashiCorp Vault and Vault Enterprise logged proxy environment variables that potentially included sensitive credentials. Fixed in 1.3.6 and 1.4.2.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://www.hashicorp.com/blog/category/vault/
Release Notes https://github.com/hashicorp/vault/blob/master/CHANGELOG.md#142-may-21st-2020

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:hashicorp:vault:*:*:*:*:*:*:*:* vault >= None < 1.3.6
cpe:2.3:a:hashicorp:vault:*:*:*:*:*:*:*:* vault >= 1.4.0 <= 1.4.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status