CVE-2020-10724

Name
CVE-2020-10724
Description
A vulnerability was found in DPDK versions 18.11 and above. The vhost-crypto library code is missing validations for user-supplied values, potentially allowing an information leak through an out-of-bounds memory read.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Issue Tracking https://bugs.dpdk.org/show_bug.cgi?id=269
Mailing List https://www.openwall.com/lists/oss-security/2020/05/18/2
Issue Tracking https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10724
Third Party Advisory https://usn.ubuntu.com/4362-1/
SUSE http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00045.html
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HRHKFVV4MRWNNJOYQOVP64L4UVWYPEO4/
MISC https://www.oracle.com/security-alerts/cpuoct2020.html
MISC https://www.oracle.com/security-alerts/cpujan2021.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:dpdk:data_plane_development_kit:*:*:*:*:*:*:*:* data_plane_development_kit >= None <= 18.11

Vulnerable and fixed packages

Source package Branch Version Maintainer Status