CVE-2019-8677

Name
CVE-2019-8677
Description
Multiple memory corruption issues were addressed with improved memory handling. This issue is fixed in iOS 12.4, macOS Mojave 10.14.6, tvOS 12.4, Safari 12.1.2, iTunes for Windows 12.9.6, iCloud for Windows 7.13, iCloud for Windows 10.6. Processing maliciously crafted web content may lead to arbitrary code execution.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
Vendor Advisory https://support.apple.com/HT210348
Vendor Advisory https://support.apple.com/HT210351
Vendor Advisory https://support.apple.com/HT210358
Vendor Advisory https://support.apple.com/HT210346
Vendor Advisory https://support.apple.com/HT210357
Vendor Advisory https://support.apple.com/HT210356
Vendor Advisory https://support.apple.com/HT210355

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:apple:icloud:*:*:*:*:*:windows:*:* icloud >= None < 7.13
cpe:2.3:a:apple:icloud:*:*:*:*:*:windows:*:* icloud >= 10.0 < 10.6
cpe:2.3:a:apple:itunes:*:*:*:*:*:windows:*:* itunes >= None < 12.9.6
cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:* safari >= None < 12.1.2
cpe:2.3:o:apple:iphone_os:*:*:*:*:*:*:*:* iphone_os >= None < 12.4
cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* mac_os_x >= None < 10.14.6
cpe:2.3:o:apple:tvos:*:*:*:*:*:*:*:* tvos >= None < 12.4

Vulnerable and fixed packages

Source package Branch Version Maintainer Status